instalação especificada do JRE não existe

Estou tentando lançar um servidor no meu tomcat 7 no meu eclipse indigo EE
e recebo o seguinte erro:

“‘iniciando o servidor Tomcat v7.0 em localhost’ encontrou um problema.
A instalação especificada do JRE não existe ”

Eu verifiquei a configuração do caminho de construção e na seção de bibliotecas eu tenho o
JDK7 como JRE System Libraray e quando eu verificar “Installed JREs …” o correto
caminho está lá – “C: \ Arquivos de Programas \ Java \ jdk1.7.0_01”.

O que mais pode ser feito? Muito Obrigado.

ps – Eu também estou usando o maven 3.0.3

Clique duas vezes no servidor para exibir a Visão geral.

Clique em Runtime Environment.

Selecione o JRE na lista suspensa. Você pode precisar configurá-lo clicando em Installed JREs e clicando em Adicionar.

Se as instruções acima não ajudaram, você pode fazer o seguinte:

1- no menu rodar escolha “Executar configurações …”

2- Escolha seu perfil de execução do maven e clique na aba “JRE”.

3- Selecione “Alternate JRE” e no menu suspenso selecione “jdk1.7xxx” (ou qualquer outro jdk que você queira usar “você também pode selecionar o jre padrão do espaço de trabalho.

Eu estava enfrentando o mesmo problema e isso ajudou.

Vá para o arquivo de construção.

Clique com o botão direito sobre ele.

Faça o seguinte conforme as capturas de canvas

insira a descrição da imagem aqui

insira a descrição da imagem aqui

Vá para PropriedadesCaminho de Construção JavaBibliotecas .

Aqui você verá uma cruz vermelha na biblioteca cujo caminho não está correto.

Selecione esta biblioteca, clique no botão Editar e altere-a para o caminho correto.

Janela -> Prefenerces -> Servidor -> Ambiente de Tempo de Execução; como isso…. insira a descrição da imagem aqui

Edite seu Apache e selecione seu diretório jdk ….

Ele funcionou depois de executar “mvn install clean -P prepare”

Para o Eclipse MARS, para projetos maven.

Depois de instalar o novo JRE conforme explicado (por exemplo, aqui: http://javahonk.com/specified-jre-installation-does-not-exist/ ), não use sua configuração antiga, MAS crie uma nova configuração .

Atualizou o Java, JRE. então eu enfrentei esse mesmo problema, tentei tudo isso, mas continuei com essa questão. então depois disso, eu removi o servidor do aplicativo e, em seguida, adicionei novo servidor e com isso eu mencionei a nova versão do JRE agora está funcionando bem.

Abra o eclipse e encontre a guia do servidor e tente abri-lo. Há clique em Runtime Environment

Selecione o JRE na lista suspensa para configurá-lo clicando em Installed JREs e em Add.

Se você usa o Maven, tente:

EclipseMavenJRE_1

EclipseMavenJRE_2

Janela -> Prefenerces -> Servidor -> Ambiente de Tempo de Execução; assim …. entra a descrição da imagem aqui

Edite seu Apache e selecione seu diretório jdk ….