Servidor GlassFish falha ao iniciar do Eclipse, ele fica preso em 69%

Eu estou tentando testar meu aplicativo da web no GlassFish 4 do eclipse. Quando estou iniciando o GlassFish 4 com um arquivo ( startserv.bat ), ele funciona bem, mas quando estou tentando executá-lo a partir do Eclipse, ele inicia o carregamento, mas o processo de boot fica preso em 69% , em uma mensagem Launching Delegate...

insira a descrição da imagem aqui

Depois de vários minutos nessa condição, aparece uma mensagem de erro:

insira a descrição da imagem aqui

Depois de algumas tentativas, recebi esta mensagem:

insira a descrição da imagem aqui

Mesmo que nada esteja sendo executado na porta 8080 (porta do GlassFish) e 4848 (porta de administração do GlassFIsh)

Funcionou bem para mim antes, mas agora, por algum motivo, isso não acontece, eu não fiz nada para suas configurações ou nada. Como posso resolver esse problema?

Aqui está o meu log de console de boot: http://pastebin.com/XL0Lh5zw (usando pastebin para evitar tornar o post grande)

Eu tive o mesmo problema, com as mesmas mensagens.

Após uma longa busca, desisti e removi o servidor.

remova o servidor

E eu removi o ambiente de tempo de execução do servidor

remova o tempo de execução

Os arquivos Glassfish não foram removidos apenas nas configurações do eclipse e, em seguida, criei novamente o Server Runtime e o Server usando o servidor glassfish existente e o problema foi corrigido: D.

Eu tenho o mesmo problema. Estou usando o Eclipse Luna.

Eu fiz o downgrade do meu GlassFish Tools para 7.2 e eu reiniciei o servidor. http://download.oracle.com/otn_software/oepe/12.1.3.1/luna/repository

Eu não vi nenhum erro no log, apenas alguns avisos sobre o material do Hibernate, que não deveriam travar o lançamento. Pode ser que esteja demorando muito para inicializar com toda a sobrecarga do eclipse, mas muito provavelmente poderia ser um problema de bloqueio, o que poderia causar o tempo limite, já que o eclipse ficaria infinitamente à espera de um recurso que nunca poderia obter. Tem certeza de que o servidor está sendo acessado apenas pelo eclipse e ainda não está em execução ou é de propriedade de outro processo?

Eu também estava recebendo esse problema toda a semana. Mas em nossa equipe nós finalmente consertamos. Parece que o Glassfish precisa do JDK 8 (portanto, não é necessário inserir o JRE 8 no Eclipse Luna), portanto é necessário instalar primeiro o JDK 8 no site da Oracle e depois configurar o Eclipse para apontá-lo no Windows -> Preferência -> Java -> JREs instalados Clique em “Adicionar”, escolha “VM padrão”, clique em “Avançar” e use o botão “Diretório” para apontar para o diretório JDK8 – recém-instalado se você não alterou nada durante a instalação, no Windows seria “C : \ Arquivos de programas \ Java \ jdk1.8.0_20 “.

Só porque as ferramentas Glassfish e Glassfish da Luna precisam que o JDK8 funcione perfeitamente.

Eu tive o mesmo problema com o GF 3.1.

Ao olhar para o problema, notei que no console Eclipse, o Glassfish parecia ainda estar em execução. Eu apaguei o aplicativo usando o console da web e, em seguida, encerrei o Eclipse. Então, verifiquei o processo Java ativo (por exemplo, ps -e | grep java ) e notei um processo Glassfish de zumbi.

Às vezes acontece que o Eclipse não é capaz de inicializar / desligar o Glassfish corretamente, “perdendo” um processo fazendo isso. Normalmente, matando o processo de zumbi corrige Glassfish e integração relacionada com o Eclipse.

Outra coisa para tentar, neste caso, é remover os aplicativos do servidor e remover o servidor do painel Servidores no Eclipse, em seguida, adicionar o servidor e os aplicativos novamente.

Estou usando o Eclipse Glassfish 3.1.1, Luna 4.4.1, Java 1.7.0_71, OS X Yosemite.

Alterar a porta de debugging (properties-> glassfish-> debug port) para a atual + 1 (por exemplo, de 8008 para 8009) toda vez que isso acontece, faz com que funcione para mim. Eu estou usando o eclipse neon 4.6.0 + glassfish 4.1

Se algum deles ainda estiver travado, vá para o domínio da pasta glassfish> domain1> config editar domain.xml altere o número da porta de escuta da rede. para qualquer outro número de porta. Reinicie o eclipse e glassfish. supondo que você tenha glassfish 4.1.1 funcionou para mim.

Eu consertei o problema usando o Eclipse Neon (4.6) e o GlassFish 4.1.1 .

Tive o mesmo problema, não sei por que isso acontece. Enfim, eu deletei o Glassfish do Eclipse e tive um novo GF configurado. Trabalhou para mim muito bem!

Usando o Eclipse Mars e o Glassfish 3.2. Eu usei o Eclipse> Ajuda> Verificar Atualizações. Duas atualizações foram encontradas e uma das ferramentas Glassfish. Permitiu que a atualização fizesse a sua coisa e parece ter resolvido o problema.

  • Vá para o caminho abaixo:

    C:\glassfish4\glassfish\domains\domain1\config

  • Além disso, o caminho onde o local do servidor foi configurado no eclipse e abra o arquivo domain.xml .

  • Descubra o número da porta 8080 e altere o número da porta diferente como 8081 …
  • Salve e feche o arquivo.

No eclipse:

  • Remova o servidor adicionado e adicione um novo servidor Glashfish.
  • Inicie o servidor. Isto resolverá o problema.